• Recently WordPress releases a new update with version 5.5. In that we got many new features.
    So we also updated our theme according to it. And uploaed all latest version in "Members Area"
    You can download latest version from your acocunt and update your theme.

    You can follow this link to get update process: Click Here
  • Your query is valuable for us, you can post your query any time.
    We are ON in week days. You will get instant support in our working hours.
    We are little slow in non-working hours, but you will get response in maximum 24 hours.
    Our working timing is
    [10:00 AM (IST) - 7:00 PM (IST)]
    [6:30 AM (CET)- 3:30 PM (CET)]
    [12:30 AM (EST) - 9:30 AM (EST)]

    Login Rules
    1. Premium users can login directly using aMember credentials, Created at the time of purchase.
    2. Free users can re-register to access forum using this link : Register Here.

Theme settings - remove categories, whole portfolio picture clickable, black page, remove sidebar

Status
Not open for further replies.
#1
Hello,

I would like to remove the categories selection, make the whole portfolio picture "clickable" and would like to make the portfolio site black as well as remove the sidebar. In addition, I'd appreciate if the whole screen width can be used for a site/post (or make it adjustable).

Attached pictures to see what I mean.

Thank you!

www.patrickbucher.at
 

Attachments

Satyendraa

Moderator
Staff member
#2
Hello there,

You can try this CSS:

Code:
figure.protfolio-img-efc{
  position: relative;
}

figure.protfolio-img-efc * a{
  position: absolute;
  top: 0px;
  left: 0;
  width: 100%;
  height: 100%;
text-indent: -9999px;
  }
figure.protfolio-img-efc h3:after {
        background: transparent;
}
.sidebar-wrapper{
display:none;
}
.content-wrapper {
    width: 100%!important;
    max-width: 1090px!important;
   }
Hope that helps

Best Regards
 
#3
Hello and thanks for your quick reply!

1st: Categories are still shown
2nd: That works, the whole picture is now clickable - thanks! However, the text is gone which was written when hovering
3rd: Page is still with white background
4th: side bar is gone - thanks!
5th: I'd like to use the whole screen width. If I play around with the percentage or the max-width, the content is not centered.

Soo many thanks for your help!

Best regards,
Patrick
 

Attachments

Satyendraa

Moderator
Staff member
#6
Hello there,

please try this code also

Code:
.portfolio-navi {
display:none!important;
}
.single-portfolio .content-wrapper .blog-content {
background:black;
}
And for width could you please first make width of content wrapper to 100% and then try this code.

Code:
.single-portfolio .container, #page {
    max-width: 100%;
}
And for text on hover please try this code by replacing previous code

Code:
figure.protfolio-img-efc * a{
position: initial;
}
All you have to do it just remove "Absolute" and write "Initial".

Kind Regards
 
#7
Hello,

first of all, your support is awesome!!

With some tweaks, I got pretty good results now! Thank you so much for your help!

Here is the code I use now:

body {
background: #0a0a0a;
}
.iziModal.th-portfolio {
background: #0a0a0a;
}
.header {
background-color: #0a0a0a;
}
.home .header {
background: transparent;
}


/*--------------Portfolio Konfiguration--------------*/
figure.protfolio-img-efc * a{
position: initial;
width: 100%;
height: 100%;
text-indent: 0px;
text-align: center;
}
figure.protfolio-img-efc h3:after {
background: transparent;
}



/*Kategorien bei Portfolio auf Startseite deaktivieren*/
.portfolio-navi {
display:none!important;



}
/*-----------------Seitenkonfiguration--------------*/
/*Seitenhintergrund Schwarz*/
.single-portfolio .content-wrapper .blog-content {
background:black;}
/*Seitenbreite*/
.single-portfolio .container, #page {
max-width: 100%;
position: initial;
}
.content-wrapper {
width: 100%!important;
max-width: 4096px!important;
text-align: center;
}
/*Sidebar deaktivieren*/
.sidebar-wrapper{
display:none;
}​

Few more things:

1: On the portfolio section,
- any chance to vertically center:
- the featured image
- the text when hovering over
- any chance to make transparency of the color when hovering over?

2: On the portfolio page itself, any chance to disable the post information like in the picture attached?

Thank you so much!
Patrick
 

Attachments

Last edited:

Satyendraa

Moderator
Staff member
#10
Hello there,

Use this code in Additional CSS "Appearance > Customize > Additional CSS"

Code:
@media screen and (min-width: 2000px) {
.portfolio-block.two-grid .portfolio-image img {
    height: 600px;
}
.blog-image {
    height: 600px;
background-position: 50% -126.7399px;
    background-size: 100% 100%!important;
}
}
This will work for you.

Kind Regards
 
#13
Hello,

I've just fixed the blog header.

In the CSS you have a command which changes the layout from 1024px.
I've added this CSS now to the custom section (basically a copy/paste from the CSS sheet of the theme and changed min width to 0 pixels), and now the image is centered vertically on all resolutions. It is a little big on smartphones, but it's ok, i know now how to handle this.

CSS:
/*---Blog header image CENTER---*/
@media screen and (min-width: 0px) {
.blog-image {
    height: 600px;
}
.plrx_enable,.blog-image {
    background-size: cover !important;
    background-attachment: scroll !important;
    background-repeat: no-repeat!important;
    background-position: center!important;
    }   }
check it now, it is live since 5 Minutes :)
https://www.patrickbucher.at/portfolio/portraits-menschen/



But i am unable to center the image on the portfolio section at the start screen.
www.patrickbucher.at

any help is very welcome.

Thanks!
 

Satyendraa

Moderator
Staff member
#14
Hello there,

Use this code in Additional CSS "Appearance > Customize > Additional CSS"

Code:
.portfolio-block.two-grid .portfolio-image img {
    height: 350px!important;
}
This will help you.

Kind Regards
 
#15
Hello,

thank you, i am perfectly fine now! Your support is awesome, really.

Here the full code for my website, if anybody is interested: www.patrickbucher.at

CSS:
/*----------Header Menu config----------*/
.header {
    background-color: #0a0a0a;
}
.home .header {
    background: transparent;
}





/*----------Portfolio config----------*/
/*---Hover over portfolio image---*/
figure.protfolio-img-efc figcaption a{
  display:table;
width:100%;
height:100%;
}
figcaption {
padding:0 0 20 0!important;
}
figcaption a h3, figcaption p{
display:table-cell;
vertical-align:middle;
}

/*---Color and transparancy on hover-over---*/
figure.protfolio-img-efc:after {
    background-color: #7f7f7f6a;
}
/*---Remove categories---*/
.portfolio-navi {
display:none!important;
}

/*---center portfolio image*/
.portfolio-block.two-grid .portfolio-image img {
    height: 350px!important;
}





/*----------Page config----------*/
/*---remove Sidebar, remove Blog info (Author, comments etc)---*/
.single-portfolio .sidebar-wrapper, .single-portfolio .blog-info-header {
display:none;
}

/*---Blog header image CENTER---*/
@media screen and (min-width: 0px) {
.blog-image {
    height: 600px;
}
.plrx_enable,.blog-image {
    background-size: cover !important;
    background-attachment: scroll !important;
    background-repeat: no-repeat!important;
    background-position: center!important;
    }   }

/*Page width*/
.single-portfolio .container, #page {
    max-width: 100%;
        text-align: center;
}
.content-wrapper {
width: 100%!important;
max-width: 4096px!important;
}

/*---Pages background black---*/
body.single-portfolio, .single-portfolio .blog-content  {
background-color:black;
}

Thank you again,
Patrick
 
Status
Not open for further replies.